Ergebnis 1 bis 7 von 7
  1. #1
    Mitglied Avatar von Pratzelwurm
    Registriert seit
    Nov 2008
    Beiträge
    38
    Danksagungen
    0

    Standard Batch-Datei Leerzeichen im Pfadnamen

    Servus!

    Threadthema sagt eigentlich schon alles.
    Ich wollte mir eben eine Batch-Datei schreiben um neue oder aktualisierte Dateien von A nach B zu kopieren, also ein Backup vorzunehmen.
    Allerdings habe ich ein paar Leerzeichen in den Dateinamen, also funktioniert es nicht richtig.
    Ich habe schon probiert den gesamten Pfad oder nur Teile des Pfads in " " zu setzen, aber das klappt nicht. Gibt es irgendwelche Platzhalter, die ich für Leerzeichen im Pfad verwenden kann?

  2. #2
    emats
    Gast

    Standard Re: Batch-Datei Leerzeichen im Pfadnamen

    Eine andere Möglichkeit wäre den Pfad in einer Kurzschreibweise anzugeben - die bekommst du z.B. so raus:

    Starte CMD und gib "dir /x" ein.

    Kopieren einer 1.txt von C:\ zum Userverzeichnis wäre z.B.:

    Code:
    copy C:\1.txt C:\DOKUME~1\Name\EIGENE~1\

  3. #3
    Mitglied
    Registriert seit
    May 2008
    Beiträge
    209
    Danksagungen
    0

    Standard Re: Batch-Datei Leerzeichen im Pfadnamen

    Zitat Zitat von Pratzelwurm
    Ich habe schon probiert den gesamten Pfad oder nur Teile des Pfads in " " zu setzen, aber das klappt nicht.
    Muss gehen. Darfst aber nur die Teile eines Pfades in " " setzen.

    Beispiel für Eigene Dateien:


    copy C:\"Dokumente und Einstellungen"\Name\Desktop\file.txt C:\"Dokumente und Einstellungen"\Name\"Eigene Dateien"
    EDIT: hab ein Fehler bemerkt.

  4. #4
    Mitglied
    Registriert seit
    Jan 2009
    Beiträge
    124
    Danksagungen
    0

    Standard Re: Batch-Datei Leerzeichen im Pfadnamen

    Zitat Zitat von live_longer
    Muss gehen. Darfst aber nur die Teile eines Pfades in " " setzen.
    Das ist irrelevant!
    Code:
    cd "eigene dateien\downloads"
    ist äquivalent zu
    Code:
    cd "eigene dateien"\downloads
    Beide Möglichkeiten funktionieren.

    Allerdings umschließen die Anführungszeichen fast immer den gesamten Pfad (Schau doch mal in den Registrierungseditor etc.)!

    @Pratzelwurm:
    Zeig doch mal deinen Code und poste die Dateinamen!
    Vielleicht können wir dir dann helfen!

  5. #5
    Mitglied

    (Threadstarter)

    Avatar von Pratzelwurm
    Registriert seit
    Nov 2008
    Beiträge
    38
    Danksagungen
    0

    Standard Re: Batch-Datei Leerzeichen im Pfadnamen

    Das hilft mir bestimmt weiter. Danke!

    EDIT:

    Hier der Inhalt der Batch:

    xcopy \\network\home\it13\name\education d:\backup\education /d /e /y /i /w /exclude:\\network\home\name\visual studio 2005
    xcopy c:\"visual studio 2005" d:\backup\education\vb-programmierung\
    pause

    Ist ein bisschen unübersichtlich, weil ich die beiden xcopy Befehle jeweils in eine Zeile gequetscht habe.

    Ich werde die Dateinamen mit den Leerzeichen einfach durch die kurzen Namen ersetzen. Sollte dann ja klappen.
    Geändert von Pratzelwurm (25. 02. 2009 um 13:37 Uhr)

  6. #6
    Imperator

    Moderator

    Avatar von frogger9
    Registriert seit
    Sep 2000
    Ort
    Monaco
    Beiträge
    52.548
    NewsPresso
    1 (Talent)
    Danksagungen
    1923

    Standard Re: Batch-Datei Leerzeichen im Pfadnamen

    das sind "Netzwerkpfade"

    Nimm mal statt den UNC die richtigen Pfade.

  7. #7
    Mitglied

    (Threadstarter)

    Avatar von Pratzelwurm
    Registriert seit
    Nov 2008
    Beiträge
    38
    Danksagungen
    0

    Standard Re: Batch-Datei Leerzeichen im Pfadnamen

    Das war mal ein guter Tipp!

    Also ich habe die Batch nun so abgeändert:

    xcopy z:\education d:\backup /d /e /y /i /w /exclude:z:\education\vb-programmierung\visual~1.lnk
    xcopy c:\visual~1 d:\backup\education\vb-programmierung\visual~1
    pause

    Jetzt fragt er mich, ob d:\backup\education ein Verzeichnis, oder eine Datei ist. Keine Ahnung warum das so ist.

    Also ich möchte folgendes machen.

    Ich das Verzeichnis "z:\education" nach "d:\backup" kopieren. Aber nur neue oder aktuellere. Er sollte mich auch nicht immer fragen, ob ich Dateien überschreiben will etc. Verzeichnisse soll er auch ohne Fragen erstellen. Also muss ich die Parameter /d /e /i /y mit zusammen mit dem xcopy-Befehl verwenden oder? Die Verknüpfung "z:\education\vb-programmierung\visual studio 2005.lnk" möchte ich vom Kopiervorgang ausschließen, daher /exclude:"Dateipfad".
    Das selbe will ich mit dem Verzeichnis "c:\visual studio 2005" machen. Es soll nach "d:\education\vb-programmierung" kopiert werden.

    EDIT: MS-DOS Pfadangaben sind doch nicht Case-Sensitive oder?
    Geändert von Pratzelwurm (25. 02. 2009 um 14:23 Uhr)

  8.  
     
     

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •