Ergebnis 1 bis 4 von 4
  1. #1
    Mitglied Avatar von xcode42
    Registriert seit
    Dec 2011
    Beiträge
    12
    Danksagungen
    0

    Standard GeSHi für MediaWiki funktioniert nicht

    Hallo Leute,

    ich versuche gerade für MediaWiki die Extension GeSHi zu installieren. Jedoch kommen bei mir immer folgende Fehlermeldungen:


    Warning: require_once(extensions/SyntaxHighlight_GeSHi/SyntaxHighlight_GeSHi.php) [function.require-once]: failed to open stream: No such file or directory in /home/.sites/26/site2190/web/books/LocalSettings.php on line 148

    Fatal error: require_once() [function.require]: Failed opening required 'extensions/SyntaxHighlight_GeSHi/SyntaxHighlight_GeSHi.php' (include_path='.:/usr/share/pear') in /home/.sites/26/site2190/web/books/LocalSettings.php on line 148


    was läuft bei mir hier schief?

    MfG xCode42

  2. #2
    Mitglied
    Registriert seit
    Oct 2004
    Beiträge
    2.298
    Danksagungen
    15

    Standard Re: GeSHi für MediaWiki funktioniert nicht

    Er kann die Datei "extensions/SyntaxHighlight_GeSHi/SyntaxHighlight_GeSHi.php" nicht finden.
    Entweder sind die Rechte nicht richtig gesetzt, oder aber die Datei nicht im angegebenen Pfad vorhanden. Du könntest mal versuchen den kompletten Dateipfad in die ini einzutragen.

  3. #3
    Mitglied

    (Threadstarter)

    Avatar von xcode42
    Registriert seit
    Dec 2011
    Beiträge
    12
    Danksagungen
    0

    Standard Re: GeSHi für MediaWiki funktioniert nicht

    problem soweit gelöst. jedoch wenn ich den folgenden code als beitrag speichern will, kommt sowas raus:

    <source lang="php">
    <?php
    $v = "string"; // Beispielcode
    ?>
    HTML-Text
    <?
    echo $v; // Ende des PHP-Codes
    ?>
    </source>

    Ergebnis
    Geändert von xcode42 (26. 04. 2012 um 22:03 Uhr)

  4. #4
    ex-Moderator Avatar von Kugelfisch23
    Registriert seit
    Oct 2007
    Beiträge
    18.640
    Danksagungen
    401

    Standard Re: GeSHi für MediaWiki funktioniert nicht

    Der Grund dafür ist, dass die SyntaxHighlight-Erweiterung in deinem Wiki gemäss http://www.drspecter.com/books/index...pezial:Version nicht aktiv ist. Wie hast du das in deinem Startbeitrag beschriebene Problem gelöst? Bist du dir sicher, dass es gelöst wurde?

  5.  
     
     

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •