Hi, ich versuche schon die gesamte Zeit meinen Eggdrop zum Einloggen zu bringen (nötig damit ich ihn auto-OPen kann)
Einen registrierten Account habe ich bereits für ihn eingerichtet.
Allerdings funktioniert der Identify nicht und er wird immer wieder rausgeworfen und versucht sich dann wieder anzumelden....

Ich hab zuletzt folgendes Script (von hier: http://baroquew.wordpress.com/2008/1...r-eggdrop-bot/) in meine eggdrop.conf integriert:

Code:
set nick "Bot"

# Set the alternative nick which the bot uses on IRC if the nick specified by 'set nick'
# is unavailable. All '?' characters will be replaced by random numbers.
set altnick "Bot2"
set identpass "xxxxxxx"
set identcmd "IDENTIFY"
set nickserv "NickServ"
.
.
.
.
# This is a Tcl script to be run immediately after connecting to a server.
bind evnt - init-server evnt:init_server

proc evnt:init_server {type} {
  global botnick nickserv identcmd identpass # don't forget to tell the script to use the global variables we defined above
  putquick "MODE $botnick +i-ws"
  putquick "PRIVMSG $nickserv :$identcmd $identpass"  # we will identify on connect
}

# All this is new
# Upon receiving "*This nickname is owned by someone else.*", we will try to identify
bind notc - "*This nickname is owned by someone else.*" identify:notc
proc identify:notc { nick uhost handle text dest } {
 global botnick nickserv identcmd identpass
  if { $nick == $nickserv } {
    puthelp "PRIVMSG $nickserv :$identcmd $identpass"
      putlog "Identifying : $nickserv (as $botnick)"
       }
       }
Der Bot an sich lief bisher, das was oben ist hab ich nur ergänzt (natürlich nicht den Botnamen etc )

Wo ist der Fehler? :/ Er loggt sich einfach nicht ein. Hatte vorher auch mal die einfachere Variante genommen:
Code:
# This is a Tcl script to be run immediately after connecting to a server.
bind evnt - init-server evnt:init_server

proc evnt:init_server {type} {
  global botnick
  putquick "MODE $botnick +iR-ws"
  putquick "privmsg nickserv :identify password"
}
(http://blog.spearcross.net/eggdrop-h...automatically/)

Beide einfach in den Scriptteil meiner eggdrop.conf kopiert.

Aufgerufen hab ich's dann über ./eggdrop botchk eggdrop.conf so wie bisher auch immer.


lg